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By the end of the session the students will be 
able to:

 Create a Google form
 Add a theme to a form
 Add questions
 Add an image and a video
 Choose a form response destination
 View and manage form responses
 Embed form into WordPress



 http://www.youtube.com/watch?v=2IxFeVXB
waQ&list=FLah0pxxnCSvutcNjWF-
w7mg&index=1

 http://www.youtube.com/watch?v=ZAQ3BnU
Zapo&list=FLah0pxxnCSvutcNjWF-w7mg
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 Create a form from your Drive:

 Click the red Create button, then Form.

 In the form template that opens, you can add any 
questions you'd like. You can also organize your 
form by adding headers and dividing your form 
into several pages.

 If you’d like those who complete your form to see 
a progress bar indicating how much of your form 
they’ve completed, check the box labeled ―Show 
progress bar at the bottom of form pages.‖



 Themes are a good way to personalize your
form or tailor it to its intended audience.

 When you first create a form, you’ll have an
opportunity to select a theme.

 If you’d like to change your theme later, click
on the button displaying the theme name in
the toolbar. Pick a theme you like, and
click OK.



Step 1: Give a name 
for your form

Step 2: Choose a 
theme and click OK 

button



Step 3: Type a name 
for this form

Step 4: Type your 
question/item here



 Add a question

 To add a question to your form, click the arrow next to the Add 
item button and select from the following question types:

 Text — respondents provide short answers
 Paragraph text — respondents provide longer answers
 Multiple choice — respondents select one option from among 

several
 Checkboxes — respondents select as many options as they’d like
 Choose from a list — respondents select one option from a 

dropdown menu
 Scale — respondents rank something along a scale of numbers 

(e.g., from 1 to 5)
 Grid — respondents select a point from a two-dimensional grid
 Date — respondents use a calendar picker to enter a date
 Time — respondents select a time (either a time of day or a 

duration of time)



Step 5: Choose preferred 
type of question (Text, 

Paragraph Text, Multiple 
Choice, Checkboxes, 

Choose from a list, Scale, 
Grid, Date or Time)



Step 6: Choose number 
scale. Example 1 to 5 (for 5 

likert scale), 1to 7 (for 7 
likert scale) or 1 to 10 (for 

10 likert scale).



Step 7: Type your 
rating scale

Step 8: Check the 
Required question 

checkbox to control your 
instrument. Respondent s 
are required to fill up all 
item in the questionnaire 

before they can submit the 
form 

Step 9: Clock on 
Done button to 

proceed



 Add an image

 To add an image to your form, click the Insert menu, and 
select Image. Once you've uploaded the image, you can give it a 
title and specify what text will appear when someone hovers over 
the image.

 Images in forms aren't attached to or associated with form 
questions. You can change the position of an image by dragging 
it up or down in your form.

 Add a video
 To add a video to your form, click the Insert menu, and 

select Video. To pick a video, either provide a YouTube video’s 
URL, or use the search box to search for a video. After selecting 
one, you can add a title and a caption to the video. 

 You can click and drag one of the video's corners to resize it, and 
you can align the video to the left, right, or center of the page by 
choosing one of the alignment options.



Step 10: Add item –
Image – Choose an 
image to upload



Example of uploaded 
image









Example of an online 
questionnaire using 
Scale question type



Example of Scale 
type question

Example of Text type 
question

Example of 
Paragraph text type 

question

Example of Date 
type question



Example of Grid type 
question



Example of Grid type 
question



Example of 
Demographic 

question



Step 10: Click here to add 
item. Choose your type of 
question. You can also add 
section header, page break, 

image or video.



 After you’ve sent out your form, Google Forms will begin 
collecting the responses you receive.

 You'll be asked to choose how you’d like to store these 
responses. (Note: You can make this choice at any time 
while editing your form by clicking the Choose response 
destination button in the toolbar.)

 You can choose either to send responses to a spreadsheet, 
or you can store them only in Forms.

 If you choose to store them in a spreadsheet, you’ll be 
able to see individual responses as they come in. 

 If you choose to store them in Forms, you’ll be able to see 
a summary of all the responses you’ve received, and you’ll 
also be able to download the responses as a CSV file.



 In the ―Choose response destination‖ dialog, you can 
choose to create a new spreadsheet in which to store 
your form’s responses. You can give the new 
spreadsheet whatever title you’d like. If you’d like all 
of your forms to collect responses in a new 
spreadsheet in the future, make sure the checkbox 
next to ―Always create a new spreadsheet‖ is selected.

 Alternatively, you can choose to collect responses in a 
new sheet of an existing spreadsheet. Choose ―New 
sheet in an existing spreadsheet...‖ and click Choose. 
You’ll see a list of your spreadsheets. Pick a 
spreadsheet by checking the box next to it and 
click Select. A new sheet will be created in that 
spreadsheet, and your form responses will appear 
there. A spreadsheet can collect responses from only 
one form at a time.



 Once you’ve chosen to store form responses in a
spreadsheet, the Choose response
destination button in the toolbar will turn into
a View responses button. Click this to see your
spreadsheet. You can also find the spreadsheet
in your Drive.

 Note that responses sent to a spreadsheet are
essentially a copy of your responses and are only
sent one way — form to spreadsheet, not
spreadsheet to form. In other words, if you
modify a response in your spreadsheet, you’re
not changing the original response, which will
show up in summary view or the CSV download.



 If you don’t want responses to go to a spreadsheet, 
click the Keep responses only in Forms button. Then, 
to access the responses you’ve collected, click 
the File menu, select Download as, and click Comma 
Separated Values.

 Keeping responses in Forms is a good way to go if 
you expect your form to receive heavy traffic or a 
significant number of responses, as spreadsheets will 
hold only the first 400,000 cells of response values. 

 Your form's summary view, as well as the results you 
download as a CSV, will always reflect all of the form 
responses that are submitted, even beyond these 
limits.



 If you’ve chosen a spreadsheet in which to 
store your form responses, you can change 
this destination at any time by clicking on 
the Responses menu in Forms and 
selecting Change response destination. 

 You’ll be taken back to the ―Choose response 
destination‖ dialog, where you can create a 
new spreadsheet or send responses to 
another existing spreadsheet.



 You can also choose to unlink your form from a 
spreadsheet at any given time by clicking on 
the Responses menu in Forms and 
selecting Unlink form. 

 The spreadsheet will no longer receive new 
responses, but responses will continue to be 
stored in Forms, available as a real-time 
summary or as a CSV file. 

 You can choose to re-link your form to a 
spreadsheet at any time with no responses lost 
or deleted.



Step 11: Click here 
to choose response 

destination



Response destination



Step 12: Click here 
to view live form



Live form



Live form



 View responses

 Once you’ve created your form and sent it to
recipients, you’re able to view the responses you’ve
received in three different ways: as a summary of
responses, in a separate spreadsheet, or as a
downloaded CSV.

 If you’d like a broad overview of how your group of
respondents answered each question, viewing the
summary is the way to go.

 If you’d prefer a fine-grained perspective on all the
data you’ve collected with your form, you’ll likely
want to view the responses in a spreadsheet or
download a CSV with response data.



 To quickly see how many users filled out a form 
and what their responses are, you can check out 
the response summary. From your form, click 
the Responses menu and select Summary of 
responses.

 If you'd like respondents to be able to see this 
same summary of responses, check the box in 
the "Confirmation page" section of your form 
labeled Publish and show a link to the results of 
this form. When this box is checked, users who 
respond to your form will see a ―See previous 
results‖ link, which they can click to view the 
response summary.



 View form responses in a spreadsheet

 To see a spreadsheet with responses to your 
form, click the View responses button in the 
toolbar.

 Download responses as a CSV

 To download all the responses your form has 
received, click the File menu, select Download 
as, and click Comma Separated Values.



 Monitor for multiple submissions

 As you're reviewing responses to your form, 
keep in mind that you can't prevent users 
from submitting a form more than once, so 
the same person may have submitted 
multiple responses.

 If you use Google Apps, you can choose to 
record the email addresses of people who fill 
out your form and then easily identify any 
duplicate responses.



 Stop collecting form responses

 To close your form to new responses, click 
the Accepting Responses button in the toolbar to 
toggle responses off. The toolbar button will then say 
"Not accepting responses." If you’d like to re-open 
your form to responses again later, you can click this 
button again to toggle responses back on.

 If a form is no longer accepting responses, visitors to 
the form will see a message letting them know their 
responses won’t be collected. To customize this 
message, change the text that appears under the 
heading "This form has been turned off," which 
appears near the top of your form.



 Copy a form or spreadsheet

 You can copy any form or spreadsheet by 
clicking the File menu and selecting Make a 
copy. 

 Copying a form will copy only the questions 
and layout, not the responses you’ve already 
received. Copying a spreadsheet will copy 
only the responses it's received, not the 
adjoining form.



Not accepting 
responses



Step 13: Click 
Responses –
Summary of 

responses to view all 
responses



Summary of 
responses



Summary of 
demographic 

responses



View responses form



 If you're working on a form and would like to share it with 
a collaborator, click the File and select Share. Then, from 
the "Sharing settings" dialog, you can specify individual 
collaborators with whom you'd like to share your form for 
editing. To add a collaborator, begin typing his or her 
name in the "Add people" text box.

 When you're working with a collaborator on a form, each 
of you can edit one input field at a time. For example, your 
collaborator can edit the text of a question while you edit 
the help text of that same question.

 When you share a Google form with a collaborator, you 
give that collaborator full editing access to the form. That 
collaborator will have the ability to make any changes 
they'd like to the form, including a change to where 
responses are collected.



Step 14: Click on File 
– Add Collaborators



Step 15(a): Copy and 
paste the link to 
share with other 

collaborators



Step 15(b): Fill up 
email address of 

your collaborators in 
order to invite them



 When you've completed your form, you can send it to 
respondents via email or by sharing the form via 
social media. 

 Just click the blue Send form button at the bottom of 
your form or at the top-right corner of your browser 
window. 

 You can choose to share a link to your form, or you 
can add names, email addresses, and groups to 
the Add people field. 

 Click the Done button, and the people you’ve added 
will receive an email directing them to your form.



Step 2: Enter name 
or email address to 

send form to 
respondents

Step 1: You can copy 
this link to embed 

into  blog or website



 Embed a form on a website or blog

 If you'd like to embed your form in a website 
or blog after you create your form, click 
the Send form button at the end of your form 
and select the Embed option. 

 Alternatively, go to the File menu and 
select Embed. You can then paste the 
generated HTML into your site or blog.



 Confirmation page settings

 Before you send your form, you may want to 
change settings related to the confirmation 
page users will see after submitting 
responses to your form. You can find these 
settings at the bottom of your form.

 To change the confirmation message users 
will see, edit the message in the 
"Confirmation message" box.



 There are other settings you can adjust as well:

 Show link to submit another response — Checking 
this box will allow users to submit as many form 
responses as they'd like.

 Publish and show a link to the results of this form —
Checking this box will give respondents access to the 
form's summary of responses.

 Allow responders to edit responses after 
submitting — Checking this box will allow 
respondents to change their answers to your form.



Step 1: You can type 
your instruction to 
guide respondent



Step 2: Check this box to 
show link to submit another 

response

Step 3: Check this box to 
publish and show a link to 

the results

Step 4: Check this box to 
allow responders to edit 

responses after submitting



 Click the Send form button at the end of your
form and select the Embed option.

 Alternatively, go to the File menu and
select Embed. You can then paste the
generated HTML into your site or blog.

 Log in to your WordPress.

 Paste the HTML link into your new post.



Step 1: Log in your 
WordPress



Step 2: Click on File – Send 
Form



Step 3: Click on 
Embed button



Step 4: Copy and 
paste HTML link to 
embed in website

Step 5: Click on 
Done button to 

proceed



Step 6: Click on 
Posts – Add new 

post



Step 7: Type a title 
of your post



Step 8: Copy and 
paste HTML link to 
embed in website



Congratulations! Your form 
has been embedded into 

your WordPress



―People share, read & generally engage more with any 
type of content when it’s surfaced through friends & 
people they know & trust‖. –Malorie Lucich, Facebook 

spokesperson


